🎮 Advanced Gaming Performance Tweaks
1. Unlock Max CPU & GPU Power for Gaming
By default, macOS balances power efficiency over performance. These tweaks prioritize speed:
A. Enable High Performance Mode (For M1/M2/M3 MacBooks)
- System Settings > Battery > Energy Mode > High Performance
B. Disable CPU Power Throttling (Intel Macs Only)
- Enter this command in Terminal (removes power limits): cssCopyEdit
sudo pmset -b dps 0
- This prevents macOS from underclocking the CPU when gaming on battery.
C. Set CPU Performance to Turbo Mode (Intel Macs)
- Run this Terminal command: javascriptCopyEdit
sudo sysctl -w hw.ncpu=$(sysctl -n hw.physicalcpu)
- This forces macOS to use all CPU cores at full power.
2. Increase FPS by Overriding Metal/Graphics Settings
A. Unlock More VRAM for Gaming (Intel & Apple Silicon Macs)
- Open Terminal and enter: arduinoCopyEdit
defaults write -g MetalForceHighPerformanceGPU -bool true
- Forces macOS to always use the dedicated GPU for rendering.
- Works on MacBook Pro (M1 Max/M2 Max), iMac, and Intel Macs with Radeon GPUs.
B. Optimize OpenGL Performance (For Older Mac Games)
- If a game only supports OpenGL, use this command: arduinoCopyEdit
defaults write com.apple.opengl AllowSpriteBatching -bool true
- This reduces OpenGL draw calls, improving FPS in older games.
C. Disable “Dynamic Resolution Scaling” (For Steam & Epic Games)
- System Settings > Displays > Resolution > Set Native Resolution
- Many Mac games auto-adjust resolution for performance, but forcing native resolution with a lower in-game render scale works better.
- Example: Set macOS resolution to 1440p, then lower in-game settings to 75% render scale.
3. Reduce Input Lag & Boost Controller Response Time
A. Reduce Keyboard & Mouse Latency
- Run these commands to increase response speed: arduinoCopyEdit
defaults write -g InitialKeyRepeat -int 10 defaults write -g KeyRepeat -int 1
- Makes WASD movement feel snappier in FPS games.
B. Enable Bluetooth Low Latency Mode for Controllers
- System Settings > Bluetooth > Click Your Controller > Low Latency Mode ON
- Reduces input delay for PS5/Xbox controllers.
C. Disable V-Sync for Competitive Gaming (Reduces Input Lag)
- Use Steam Launch Options for games like CSGO or Dota 2: diffCopyEdit
-novid -high -nojoy -nod3d9ex -tickrate 128 -threads 4
- This removes menu lag and forces 128-tick servers.
4. Optimize Cooling for Maximum FPS
A. Control Fan Speed to Prevent Thermal Throttling
- Macs Fan Control (Download Here) lets you manually set fans to higher speeds before gaming.
- Helps Intel Macs and M1/M2 MacBooks stay cooler, preventing FPS drops.
B. Undervolt Intel CPUs to Reduce Heat (For MacBooks with Intel CPUs)
- Use Volta (Download Here)
- Reduces power draw by -80mV, which lowers heat and prevents FPS drops from overheating.
🖥 External Display: Max Performance & Color Accuracy
1. Force 120Hz Refresh Rate on External Monitors
- If your Mac doesn’t let you choose 120Hz, force it with this: arduinoCopyEdit
defaults write -g com.apple.windowserver AllowProMotion 1
- Works on Apple Studio Display, Pro Display XDR, and some gaming monitors.
2. Reduce Latency on External Displays (For Gaming Monitors)
- Use DisplayPort instead of HDMI
- HDMI adds extra lag unless using HDMI 2.1.
- Set response time to “Fast” in your monitor’s settings (if available).
3. Use BetterDisplay App to Enable HiDPI Scaling
- Download: BetterDisplay
- It forces macOS to use Retina-style scaling, making text sharper on non-Apple monitors.
🔋 Advanced Battery Tweaks (For Maximum Life & Efficiency)
1. Control Battery Charging for Longevity
- Use AlDente (Download Here)
- Stops charging at 80% to extend battery lifespan.
- Essential for MacBook users who game while plugged in.
2. Limit Background Services Draining Power
Run this Terminal command to disable unnecessary processes:
swiftCopyEditlaunchctl unload -w /System/Library/LaunchAgents/com.apple.PhotoAnalysisDaemon.plist
launchctl unload -w /System/Library/LaunchAgents/com.apple.AOSPushRelay.plist
- Stops photo indexing and iCloud sync when not needed, saving CPU cycles.
3. Enable “Deep Sleep” Mode for Better Battery Life
- By default, MacBooks use Power Nap, which drains battery in sleep mode.
- Run this command to force true sleep mode: cssCopyEdit
sudo pmset -b powernap 0 sudo pmset -b standbydelaylow 60 sudo pmset -b sleep 10
- This puts your Mac into hibernation faster, saving battery overnight.
🚀 Extra Power User Tricks
1. Reduce Finder’s CPU Usage (For More Gaming Power)
- Disable Finder preview thumbnails, which use GPU/CPU in the background: arduinoCopyEdit
defaults write com.apple.finder QLInlinePreviewMinimumSupportedSize -int 512
- Restart Finder: nginxCopyEdit
killall Finder
2. Use Terminal to Monitor FPS in Real Time
- Open Terminal and enter: perlCopyEdit
sudo powermetrics --samplers smc | grep -i "GPU"
- Shows live GPU usage & FPS performance for your game.
3. Free Up RAM Before Launching a Heavy Game
- Run: nginxCopyEdit
sudo purge
- Clears cached RAM, freeing up memory for smoother gaming.
🔥 Final Setup for Maximum FPS & Performance
✅ Enable High Performance Mode (M1/M2 MacBooks)
✅ Force Dedicated GPU Usage (Intel/Radeon Macs)
✅ Adjust Refresh Rate & Scaling (External Monitors)
✅ Use Macs Fan Control (To Prevent FPS Drops)
✅ Use AlDente (For Battery Longevity)
✅ Reduce Background Tasks & Services